AutoStarSuite.Net

Your Source for Meade AutoStar, AutoStarSuite, LPI, DSI and Telescope information
Welcome to AutoStarSuite.Net Sign in | Join | Help
Home Blogs Forums Photos Files Astronomy News

DSI and LPI with Envisage 7.05

Last post 02-07-2009, 2:06 AM by mwallace. 2 replies.
Sort Posts:
  •  02-05-2009, 4:28 PM

    DSI and LPI with Envisage 7.05

    Recently acquired used LX90 telescope with DSI and LPI, have spent hours reading forums trying to find a solution to communication problems. The DSI and LPI manuals don't show Envisage screen the same as on the program and I can't figure out how to get buttons to work correctly.

    I can use Autostar Suite 5.0 on Vista Home Premium SP1 32-bit Toshiba Laptop with LX90 on com port 4 to guide scope.  PC has a webcam (Trust Webcam) that I don't use and close it's toolbar when starting up since the toolbar is in my way.  I'm successful in aligning, viewing the sky and taking autostar tours. I was finally successful in getting laptop to recognize DSI after copying the dsiusb.sys driver file dated 1/15/2008 from the Meade Driver folders and pasting it to write over an older version in the windows system32 drivers folder. 

    1. DSI Problem: When I choose Imaging DSI in Autostar Suite and Envisage opens up, many buttons are grayed out.  In addition the connect button only gives a choice to connect through network server but I'm already connected via com port and insists that my telescope is not connected.  (the PC is connected to the Autostar hand controller port).  I also get a "Firmware Command was rejected".  I had read that using a com port was more secure than a network server and I'm assuming you can't use both at the same time. I use the option under telescope menu in Autostar Suite connect via com port. Can anyone explain what I'm doing wrong?

    2. LPI Problem:  When I choose Imaging LPI in Autostar Suite, Envisage opens up but doesn't show LPI as a device.   When I check system device drivers, the LPI shows up with properties that say "this device cannot start" (Code 10) and the driver is dated 6/24/2004. I'm unsuccessful in trying to update the driver or ask Microsoft to find a solution.  Driver details:  Windows\system32\drivers\DsiUsb.sys File version 1.06.  I find a DsiUsb.sys file dated 12/13/2004.  In trying to troubleshoot I activated the LPI Install wizard which apparently put the old driver back in place.  After putting the 1/15/08 driver back in the Win/Sys32/driver file, I tried again but it still is pointing to file version 1.06 even though the newer driver is in the win/sys32/driver folder it accesses. My PC is not recognizing the LPI.  Why doesn't the LPI properties at least give the latest driver version for the dsiusb.sys 1/15/2008?

  •  02-05-2009, 6:58 PM

    Re: DSI and LPI with Envisage 7.05

    Hi, mwallace

    You can only have one connection at a time to the Autostar handset. If you will close the Autostarsuite connection, you will find you can connect directly from Envisage. Instead of using the network addres, type COM4 (or whatever port number is right for your computer) in the connection box on the telescope tab. That will get you going.

    If you *really* want to connect both Autostarsuite & Envisage you have to use the netscope server applet:
    http://autostarsuite.net/forums/3250/ShowPost.aspx

    This will let you run both, plus remote handbox if you like.

    To get your LPI going, do a search on this site for "trust webcam". There are a number of threads that deal with this issue, this one is probably the most succinct:
    http://autostarsuite.net/forums/post/18138.aspx

    HTH,

    Chuck

    Chuck Reese
    CDIP Certified: Nebula, Galaxy, Solar System, Stars & Clusters Imager
    CDIP Mentor: Nebulae & Solar System Categories
    For information on the Certified DSI Imager Program, see:
    http://autostarsuite.net/forums/1427/ShowForum.aspx
  •  02-07-2009, 2:06 AM

    Re: DSI and LPI with Envisage 7.05

    Thanks, Chuck, for the clarification that I don't need to open Autostar to use Envisage and that they can't both be connected at the same time using a com port.

    The link you gave with instructions on editing the registry was excellent. I had read other posts but didn't do anything because both the DSI and LPI were not connecting and I thought that solution didn't apply.  But it was the solution to get the LPI driver recognized.  My registry had a total of 14 occurrences of Trust Webcam 14823.  I edited a total of 11 Driver Desc, Friendly Name, and Display Names that came up.  Three Device Desc: @oem31.inf,%usbdevicdesc%;Trust Webcam 14823 could not be edited so I ignored them.  When I restarted the computer I had success.  I could now see the LPI in Envisage.

    I also solved the connection problem I wrote of with the DSI recognized by Envisage but not being able to connect the scope and which also existed with the LPI now that its driver was recognized. I made the same mistake as an earlier forum poster by typing the name of the scope in the place where I should have typed the com port number, and also discovered how precise I had to be when typing the com port.  I tried comm port 4, com port 4, etc. and nothing was working.  Finally, I went to Weasner's collection of saved posts where *** Seymour has a screen shot: http://www.weasner.com/etx/archive/feedbackJul06/autostar_suite.html which showed com6 (no spaces).  I put in my com4 and couldn't believe that this simple difference was the answer.  I saw "connected" and Autostar ver 43Ea autotrack only (will have to correct the autotrack setting another time since I don't use an equatorial mount). Another step forward. Clouds have come in so further progress will have to wait for another night.  For anyone reading this post, p. 26 and 31 of the original DSI manual have a photo showing the com entry.  I missed this because I was starting with the LPI thinking it was easier and the LPI manual doesn't have any screen shots of the com settings.
View as RSS news feed in XML

AutoStarSuite.Net

Powered by Community Server, by Telligent Systems